首页 九州天下现金娱乐 安全公告
正文

九州娱乐区注册开户 Struts2框架远程代码执行漏洞安全预警与建议

发布时间:2022-04-15 14:04   浏览次数:3245

近日,亿豪国际app信息安全威胁情报中心监测到Apache Struts官方发布安全公告,披露了Apache Struts框架漏洞S2-062 (CVE-2021-31805),攻击者可构造恶意的OGNL表达式触发漏洞,从而实现远程代码执行。目前Struts官方已发布安全版本,亿豪国际app信息安全应急中心建议受影响单位和用户立即升级至安全版本。

九州娱乐区app下载中心

该漏洞由于对s2-061(CVE-2020-17530)的修复不完整,导致输入验证不正确。 当开发人员使用了 %{…} 语法进行强制OGNL解析时,仍有一些特殊的TAG属性可被二次解析,导致攻击者可构造恶意的OGNL表达式触发漏洞,从而实现远程代码执行。

九州天下现金娱乐体育真人

影响范围:2.0.0 <= Apache Struts版本 <= 2.5.29

利用条件:漏洞需要开发实际代码写法支持,目前判断被利用的 实际风险较低

九州娱乐区官网平台

目前 S truts官方已发布安全补丁,亿豪国际app信息提醒各相关单位和用户要强化风险意识,切实加强安全防范:

目前Struts官方已发布安全版本:2.5.30。建议用户尽快自查,对受影响的版本及时升级至最新版本: https://cwiki.apache.org/confluence/display/WW/Version+Notes+2.5.30

九州娱乐区最新网址

1、若项目是采用 maven 编译,可查看pom.xml文件确定struts2使用的版本号是否在影响范围内,如下2.5.10版本在受影响版本范围内:

444.png


2、在应用目录下搜索是否使用struts2-core,特别在应用的WEB-INF\lib目录下搜索,如果存在struts2-core-{version}.jar,且查看所使用版本号是否在受影响范围内,如下2.5.10版本在受影响的版本范围内:

5555.png

附参考链接: https://cwiki.apache.org/confluence/display/WW/S2-062

福建九州娱乐区有限公司 版权所有  联系: [email protected] 闽ICP备06011901号 © 1999-2023 Fujian Strait Information Corporation. All Rights Reserved.

返回顶部